プラグインの更新などでFTP接続を要求される場合の対処

「FTPの接続情報を入力してください」と言われたら

以下の画面が表示されてFTP接続のための入力を要求されることがあります。
どうもこれはWordPressの動作しているフォルダ環境とWebサーバのオーナーが異なる場合にWordPressが更新する時に実行するスクリプトがFTP接続で更新する処理になっているようです。XAMPP、MAMP、NASなどのローカル環境で使用しているとこの現象が発生することが多いようです。
対処方法は以下です。

WordPressの動作しているフォルダ環境のオーナーを変更する

このコマンドでユーザーとグループの所有者をスクリプト実行するものとファイル作成するものと合わせるために変更します。
XAMPPやMAMPのような同じPCやMac内だとこれで現象は解消されますが、NASの共有フォルダがWebフォルダの場合はうまく動作しません。(理由はわかりませんがうまく動作しませんでした・・)この場合は以下の対処方法を取ります。

wp-config.phpに設定を追加

直接ファイルを更新できるように以下をwp-config.phpに記述します。

これは以下のコードより上に記述します。